Мобильный Контент
iosAndroidWindows PhoneTizenBlackberry
— Приложения и игры Android, iPhone, iPad. Аналитика. Реклама.

Приложения в Google Play должны поддерживать Android 9 Pie к 2020 году

23 февраля, 2019
Приложения в Google Play должны поддерживать Android 9 Pie к 2020 году В 2017 году Google запланировал улучшить приложения для своей мобильной операционной системы, обязав разработчиков использовать определенный набор API и преимущества наиболее современных функций платформы. С ноября 2018 года все новые обновляемые приложения должны поддерживать Android 8.0. Теперь Google подробно рассказывает о требованиях по поддержке Android 9.0 Pie в этом году.

Начиная с августа 2019 года, новые приложения, публикуемые в Google Play, должны поддерживать API уровня 28 и выше. К ноябрю обновления уже существующих приложений обязаны поддерживать Android 9. Ежегодные требования были введены в тот же год, что и сама инициатива. Уже опубликованные в магазине приложения, не получающие обновления, эти требования не касаются.

Google отмечает, что введение требований по соответствию приложений новым версиям платформы привело к тому, что «пользователям на Android теперь доступно больше приложений с современными API, чем кода бы то ни было ранее». В 2018 году более 150 000 программ на Android стали поддерживать функции, представленные в Oreo.

Кроме Google Play, китайские сторонние магазины приложений от Huawei, Oppo, Vivo, Xiaomi, Baidu, Alibaba и Tencent потребовали от разработчиков гарантировать совместимость своих подуктов как минимум с API уровня 26 в 2019 году.

Кроме того, Google стремится защитить пользователей Android, особенно тех, что загружают приложения не из Google Play. По информации компании более 95% шпионских программ, обнаруженных за пределами официального магазина, нацелены на API уровня 22 или ниже, что позволяет им избежать подачи запросов на запуск, появившейся в Android 8.0 Oreo.

Расписание Google по реализации новых требования выглядит так:

  • Август 2019 года: в ходе установки новых приложений будет выдаваться предупреждение, если они не совместимы с API уровня 26 или выше.
  • Ноябрь 2019 года: при установке обновленных версий уже существующих приложений система выдаст предупреждение о несоответствии API уровня 26 или выше.
  • 2020 год и далее: Требования к уровню используемого приложениями API будут повышаться ежегодно.
.

Постоянный адрес публикации: http://www.procontent.ru/news/31425.html



Издатель: Procontent.ru , источник: 9to5google  
RSS-подписка на новости рубрики

Главные новости:

WhatsApp никогда не будет защищенным: критика от создателя Telegram WhatsApp никогда не будет защищенным: критика от создателя Telegram
Обзор Android Q Beta 1: что нового Обзор Android Q Beta 1: что нового
Dragalia Lost: обзор качественной и почти бесплатной РПГ на телефоны [Android и iOS] Dragalia Lost: обзор качественной и почти бесплатной РПГ на телефоны [Android и iOS]
Rangers of Oblivion: обзор ММОРПГ на Андроид в стиле Monster Hunter Rangers of Oblivion: обзор ММОРПГ на Андроид в стиле Monster Hunter
Обзор iSkySoft Data Recovery: восстанавливаем удаленные файлы с компьютера, флэшки, SD-карты Обзор iSkySoft Data Recovery: восстанавливаем удаленные файлы с компьютера, флэшки, SD-карты
Обзор лучших игр про космос на Андроид 2019 Игры про космос на Андроид: обзор лучших на 2019 год
ММОРПГ на Андроид: обзор лучших игр за 2017 год (топ-15) ММОРПГ на Андроид: обзор лучших игр на 2019 год (топ-40)
Tropico на iPad: обзор легендарной стратегии на сенсорных экранах [iOS] Tropico на iPad: обзор легендарной стратегии на сенсорных экранах [iOS]